[home]   [news]   [Palm OS]   [Treo]   [Windows Mobile]   [support]

RNS:: TopGuardEx forum thread

Resco Explorer v5.02.2 and RNS TG EXRNS:: logo
cmlx wrote: May 6th, 2009
[quote]Hello, I've found a strange problem that occurs only with RNS TG EX and Resco Explorer. I realize this appears to be a TG EX problem and not RE.
1. Resco Explorer OPEN or VIEW of a file is active when the Centro turns off
(Preference,Power Auto-Off is 1 minute and Auto-Keyguard when power is turned off). Or the phone is turned off manually by depressing power.
2. Power on. TG EX keyguard is displayed.
3. Dpad center to unlock.
4. Press "Done" in Resco Explorer to exit OPEN or VIEW.
5. Ghost image of TG EX status indicator is seen in Resco explorer directory display.
http://img2.imageshack.us/img2/4889/tgesetting.jpg
http://img14.imageshack.us/img14/2773/tgeghost.jpg
6. Keys are non-responsive. Turning the phone off then on again does not
restore keys.
7. A hard key mapped to launch another application is successful. A subsequent return to Resco Explorer works and the TG EX ghost image is gone.
This only occurs if TG EX is set to display status of either Bluetooth, phone signal or battery level. IF TG EX does not display any status, then the problem does not occur.
Tried the same scenario with Palm Memo edit, Palm Task, Agendus task edit, vfsi edit. No other application fails. [/quote]

http://www.resco.net/forums/ShowPost.aspx?PostID=23871

And the ghost image can also be seen in Xiino and Messaging...

Radoslaw Nowak (RNS::) wrote: May 10th, 2009
Also in Messaging? Where exactly?

cmlx wrote: May 17th, 2009
http://img195.imageshack.us/gal.php?g=200951211233.jpg

For example, messaging and ptunes have ghost images.

cmlx wrote: May 17th, 2009
http://img195.imageshack.us/gal.php?g=200951211233.jpg

Messaging and pTunes ghost images.

Radoslaw Nowak (RNS::) wrote: May 20th, 2009
Hmm... Can you describe the steps to get the ghost images in Messaging?

cmlx wrote: May 20th, 2009
Well, in messaging the ghost image appears randomly, but in ptunes and xiino, when I press the power button to power off the device in these two apps, and then press power button to power on the device, the images appear everytime.

Radoslaw Nowak (RNS::) wrote: May 22nd, 2009
Thanks for all your diagnostics.

I just tried changing several things in the TopGuardEx's source code again, but unfortunately nothing works. I mean, I find no other way to implement phone/battery/bluetooth indicators on the original KeyGuard, than the method that I already use.

The best thing I can do now is to add an option to exclude TopGuardEx in selected applications - there will be no indicators over these apps, but there also won't be any ghost images.

cmlx wrote: May 22nd, 2009
Thanks, probably "exclusion list" is the only way to solve this annoying problem.

PastRNScustomer wrote: November 1st, 2009
Just an update... I was the original user that reported this bug to Resco Explorer.
http://www.resco.net/forums/ShowPost.aspx?PostID=23871

The Resco developer (cmlx ?) said he contacted you.

I've just found that freeware KeyGEX 1.7 from ahsirg at http://ahsirg.kvplab.com/dp/ is a keyguard that also displays bluetooth,phone,battery,volume status.

Yet, KeyGEX does not have the ghost image bug.

Also, I did re-enable TGEX once more just to validate the ghost image bug still exists; it does.

Interestingly, I noticed a new aspect of the bug. The ghost image is actually executable. Meaning, if the ghost image of the bluetooth icon is pen-selected, the bluetooth preference is launched.

darrin wrote: November 18th, 2010
when i started using tgex, my treo 680 locks up or resets. since i bought topcrash log, here's what it says when tgex is enabled :
reset (date/time) :
date & time, fatal exception at address 73372A36
or
date & time, emul68kmain.c line 456 line 1111 exception at address 73372a36
i had all the tgex options enabled when i was using it.
i disabled tgex and uninstalled it for now. as a palm programmer, i know these things can be difficult to debug and may take a while to fix.
i have resco explorer installed but was not using it when it crashed. it has not crashed since i uninstalled tgex so i know it's the problem.
in the crash log it also shows it crashed with inboxtogo (memorymgr.c line 5346 chunk under-lock), datebk6-resources, and teallock (bitmap.c line 1085)
Forum navigationRNS:: logo
All threadsClick here to go back to the list of threads.
Add new message to this threadRNS:: logo
Posting to this forum has been permanently disabled.
[home]   [news]   [Palm OS]   [Treo]   [Windows Mobile]   [support]   [updates]   [forums]
Palm, Treo, and Centro are trademarks or registered trademarks of Palm, Inc.
Copyright © 2019 RNS::

RNS:: website navigation:
RNS:: home page RNS:: news RNS:: Palm OS software RNS:: Windows Mobile software RNS:: support RNS:: update policy